package.json 1.9 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667
  1. {
  2. "name": "slides",
  3. "version": "1.0.0",
  4. "description": "Markdown presentations",
  5. "main": "app.js",
  6. "scripts": {
  7. "start": "node app.js",
  8. "webpack": "webpack --progress",
  9. "postcss": "postcss --verbose -o public/index.css css/index.css",
  10. "clean": "rm public/*.js public/*.css public/*.map || echo clean!",
  11. "firebase": "firebase deploy",
  12. "pages": "gh-pages -d public",
  13. "deploy": "bash deploy.sh"
  14. },
  15. "author": "Gwilyn Saunders",
  16. "license": "MIT",
  17. "dependencies": {
  18. "@fortawesome/fontawesome-svg-core": "^1.2.12",
  19. "@fortawesome/free-solid-svg-icons": "^5.6.3",
  20. "@fortawesome/react-fontawesome": "^0.1.3",
  21. "draft-js": "^0.10.5",
  22. "express": "^4.16.4",
  23. "highlight.js": "^9.13.1",
  24. "qs": "^6.6.0",
  25. "react": "^16.7.0",
  26. "react-dom": "^16.7.0",
  27. "react-helmet": "^5.2.0",
  28. "react-redux": "^6.0.0",
  29. "redux": "^4.0.1",
  30. "redux-persist": "^5.10.0",
  31. "reset.css": "^2.0.2",
  32. "showdown": "^1.9.1",
  33. "showdown-highlight": "^2.1.3"
  34. },
  35. "devDependencies": {
  36. "@types/classnames": "^2.2.7",
  37. "@types/draft-js": "^0.10.27",
  38. "@types/highlight.js": "^9.12.3",
  39. "@types/qs": "^6.5.1",
  40. "@types/react": "^16.7.18",
  41. "@types/react-dom": "^16.0.11",
  42. "@types/react-helmet": "^5.0.8",
  43. "@types/react-redux": "^6.0.12",
  44. "@types/redux": "^3.6.0",
  45. "@types/showdown": "^1.9.1",
  46. "autoprefixer": "^9.4.4",
  47. "classnames": "^2.2.6",
  48. "css-loader": "^2.1.0",
  49. "cssnano": "^4.1.8",
  50. "dts-css-modules-loader": "^1.0.0",
  51. "gh-pages": "^2.0.1",
  52. "postcss": "^7.0.7",
  53. "postcss-import": "^12.0.1",
  54. "postcss-loader": "^3.0.0",
  55. "postcss-preset-env": "^6.5.0",
  56. "postcss-scrollbar": "^0.2.1",
  57. "postcss-typescript-css": "^0.2.1",
  58. "style-loader": "^0.23.1",
  59. "ts-loader": "^5.3.3",
  60. "tslint": "^5.12.0",
  61. "typescript": "^3.2.2",
  62. "webpack": "^4.28.3",
  63. "webpack-bundle-analyzer": "^3.6.0",
  64. "webpack-cli": "^3.2.1"
  65. }
  66. }